1999 Mk2 1.8 hesitation/misfire under 2500rpm


I have an issue that I’m trying to troubleshoot. I’ve got a hesitation / Misfire under anything more than light acceleration when under 2500rpm. It will happily rev to redline once you get past 2500rpm. It seems to be the classic bogging down issue that haunts the NB, but I’m having trouble finding the cause.

For context, I bought this car (Mk2 1.8 SE on 150k miles) back in June for the grand sum of £500. Welded up a sill that was stopping it get through the MOT and then got it back onto the road. Then I started dealing with the mechanical engine issues.

Initially I had a jerky acceleration at low rpm, so I changed the HT Leads and Spark plugs. Initially this was a bit better, but then It started misfiring badly.

I bought a good used Coilpack to replace it. While I was changing the Coilpack, I removed the Valve cover, cleaned it, painted it and replaced the gasket with a genuine mazda one. I torqued it all down properly as per the spec to 5.5nm.

While the misfire from startup has now gone, it is bogging down under load under 2500rpm. It’s worse the higher the gear you are in.

First I changed the MAF sensor as that was a suspect cause and a cheap replacement. No joy, made no difference.

I’ve just changed the fuel filter as it well overdue and pretty grotty, hoping that would fix it, but unfortunately it’s still bogging down. That said the engine does seem a little happier when at high revs.

I was advised it could be the 02 Sensor on the exhaust header. This connects right in front of the valve cover. I disconnected it, let the car warm up and tested it. It made no difference and the cars still doing it. So I can assume it’s not at fault.

So next possible issues are:

  1. Weak Fuel Pump - Replace with a new one?
  2. Catalytic Convertor - The exhaust from the cat back is very rusted and could do with being replaced.
  3. A vacuum leak somewhere? one of the metal clips that hold the airbox on has broken, so its cable tied down. Not sure if this would cause an issue?

Is there anything I should look at?

I had a coolant leak that was dripping coolant all over the Crank Position Sensor for a while before I found it and repaired it. Could it possible that this is damaged? The lead to the CPS was also flapping around from a bodged previous repair and was physically rubbing against one of the belts and had almost started wearing through the cable before I noticed and secured it back properly. So I’m not sure if the CPS sensor might be a bit borked.

Other than this I’m not sure where to look. Any advice would be great.


have you just filled up with e10 fuel? - you probably would not notice at the pump

Nope, was running E5 Super when it started happening. Put in a tank of E10 after, which seemed to make no difference. Now back to a full tank of Esso E5 99.

Sorry to hear you’re having problems with yours, mine hesitates to start but then has the opposite problem, which is that I can’t touch the pedal at all without it going straight to 2k RPM. Bit of an annoyance when trying to pull out of parking.

Anyways, these cars are strange. They don’t really break down but when they do, you replace everything and it still doesn’t want to work right. I changed the battery, coil packs, leads, plugs, belts, filters, water pump and fuel pump and mine still hesitates to start.

But in your case, I don’t think it will be the fuel pump, since you say it’s very happy at high revs, where it requires a lot of fuel. I would think it would be obvious if it was starved of it then. It could be that you just need a new ECU, doesn’t seem to be an all too uncommon problem.

Could it possibly be a the timing belt jumping a notch? I’ve seen a few similar threads where it’s jumped a notch or not been set right and it’s caused this problem.

1 Like

Another possibility is a faulty throttle position sensor. Have you had a diagnostic tester on the car? I had a similar problem on my very early (pre OBD2) NB and the LED tester correctly indicated the fault.

I was going to suggest the CPS .
I bought a 5 that had similar issues , it turned out to be oil from the cam cover gasket tracking down the CPS wiring lead on to the sensor.
I changed the gasket, cleaned the wiring lead and sensor… no more issues :white_check_mark::white_check_mark::white_check_mark::white_check_mark:
Also check the gap correct

Maybe I’m misreading this but you say you disconnected the o2 sensor and it made no difference, so you assume it’s ok.

This would indicate to me that it’s actually faulty as it surely should make a difference if you disconnect it.

1 Like

oh god, I feel so daft no realising that. Very good point. I’ll source a new 02 Sensor and report back.

Before you replace it, just try disconnecting and reconnecting a few times, maybe with some contsct cleaner as well.
It’s just possible you have some light corrosion in the connector, just enough to interfere with the signal.

1 Like

Thanks, I just tried cleaning it with contact cleaner, and initially it seemed to fix it. Then the engine warmed up and it started doing again. It means it its definitely tied to the engine being warm. The temperature gauge seems to work correctly on the dials, so I’m not sure if that means the coolant temp sensor is fine.

I’m sourcing another 02 sensor, so I’ll see if that does it.

Mines a pre-odb2 car also. How do you test for this? I’ve got a multimeter if that works?

My daughter had a Fiesta that had similar symptoms.
Replacing the coil packs would give a temporary solution but it took a new O2 sensor to cure it.
Fingers crossed it fixes your car.
Presumably, disconnecting the O2 sensor has no effect, warm or cold.

Mine is obd2 but iirc, you have to read pulses or flashes and decipher them to get the correct code.
Hopefully, someone who knows will be along soon to help.

I took it for a run a round the corner week or so back with the 02 unplugged and it made no difference. I’ll give it a slightly longer run and double check that unplugging the 02 makes no difference,make sure it’s warmed up properly.

1 Like

I found the sensor did not want to come out.
You can buy special sockets with a slot down one side for the wire. I found this to be fine for fitting the new one but too flexible to take the grunt needed to dislodge the old one.
The sensor was a bit like a spark plug with a ceramic insulator, so, taking advice from the Internet, I broke the ceramic portion off, so I could use a conventional socket to dislodge it.
I warmed the engine up, sprayed the thread and heaved on the socket in cycles until it eventually gave in.
You might be luckier though.

1 Like

I’ll get it soaking in GT85 a day or so before, try and make it easier for myself.

1 Like


“Autolink” and a few other vendors sell a simple LED lamp tester plus a wire link to connect to the diagnostic socket which is a small grey box (marked "Diagnosis”!) situated in the passenger side of the engine bay, adjacent to the intake “trumpet”. This was Mazda’s own pre OBD 2 design. The kit costs less than £10.

The instructions come with it; they are fairly straightforward. The sequence of flashes of the LED lamp indicate any system faults.

Diagnostic connector fault code reader LED, Mazda MX-5 mk1 & mk2, Eunos MX5 | eBay


The CPS sensor itself is a simple device and there to signal the engine rpm to the ECU. It generally either works, or not. However if the air gap to the metal tag it’s meant to detect is too wide it can cause a misfire. As mine did after it got disturbed during a cam belt change……Resetting the gap cured it.


Just reset the gap, used a credit card that was 1.2mm to set it. Doesn’t seem to have made a difference yet.