How do I edit a post?

I have a thread running entitled ‘Who is getting a 30AE’. Whenever somebody lets me know they are getting one I add their ID and special edition number to my original post in the thread. Just used to press the edit button to make the changes on the old forum. Can’t find any way of editing my post on the new forum.

On the bottom of your own posts to the left there should be a pencil symbol.

I’m seeing it on my other posts including my initial post on this thread. I’m seeing it on posts that I’ve made on the old and new forums. It isn’t showing on the ‘Who is getting a 30AE’ thread though.


Hi Roadie

I’m guessing it was a post originally started on the old forum. They have been ported across but no edit possible with our new ID’s; you can delete by choosing the options(three dots). I would copy the old info to a new editable post.

Do you see the 3 dots?


Yes I’m seeing the three dots but clicking on it doesn’t open up an editing option.

Okay, I think there’s a setting that locks a post from being editable a certain number of days after it was created. I’ll have a dig about later after the Rugby.

1 Like

@Roadie, can you try now and let me know the result?

Still no editing pencil even after clicking three dots. Tried both on Windows 10 PC running Firefox and also Android phone also using Firefox.

No, it will be a setting at this end, just need to work out what it is and figure if it can be changed.

1 Like