Stubby aerial no signal?

  1. My model of MX-5 is: __ NC1
  2. I’m based near: __ Halifax
  3. I’m looking for technical help or recommendations on: __

Hi,

Looking for advice on why my radio won’t work. I put a new head unit in my NC1 and put a stubby aerial on the back end but now I have no radio just white noise! What can I do to get it back?

Cheers

Tey refitting the original aerial and see if that works first. Failing that, if you’ve replaced the head unit at the same time check your connections. I replaced my aerial for a stubby using the stock bose head unit and had no issues other than a slightly weaker signal on a couple of stations that already weren’t great.

2 Likes

Was there any particular make/model of aerial you bought? I am going to get one but want to get one that does not affect the signal for the radio transmissions of course.

1 Like

Did you connect the power wire from the head unit to the aerial? There is an amplifier at the base of the aerial and the radio sends power to it when working as a radio.

See various threads here about harnesses and adaptors between new headunit and mazda loom.

2 Likes

I had both the IL MotorSport and moss aerials. I stuck with the moss as it’s smaller.

2 Likes

Erm… I will look tonight. I’m not sure I did.

I think it was Jass Performance that’s not to say it doesn’t work it might be just me not connecting everything. I will look tonight and update.

1 Like

Erm… I binned that :rofl: :man_facepalming:

You should normally get some signal (and not just white noise) on the stronger radio stations even with no aerial fitted, so I’d be looking at your connections rather than at the aerial itself.

1 Like

Suggest as above, have you inserted the aerial connection fully?

1 Like

I will double check tonight. You are like my MX5 guru on here :rofl:

I have a Moss stubby on my NC1 and the reception has been great.

1 Like

Just a question.
Is your new head unit just DAB or FM too?
As if you are tuned into the DAB your existing aerial won’t work with that and you will need to fit some “Form” of DAB one.
I bought the stubby before changing head unit and worked fine.
Still working with the new unit on the FM side too.
Left it on as it looks better, but use DAB now.
(From experience).

1 Like

Sorry for the late reply. It was just the Jass performance It turns out it was just me and nothing to do with the aerial. I need to put it in the right port :rofl: :man_facepalming:

Shorty Aerial Antenna NC & ND (jassperformance.com)

4 Likes

Glad you got your issues sorted. I will choose between the Jass performance and Moss.

1 Like

Possibly a silly question, but is the head unit set up for DAB?

No it was just me not plugging in the aerial :joy::joy:

2 Likes