Engine won't rev above 2,250!!?

Hi everyone. I’ve been having an intermittant problem for some while and it’s just returned. I was hoping that someone else may have experienced the same, or something similar, and have discovered the cause of the problem.

She’s a 1992 Eunos Roadster import with 82k on the clock and 20k on a new engine block. I’ve replaced plugs and leads and reset the base idle and she runs just fine then, one day, I’ll start her and she’ll fire perfectly, idle perfectly and sound sweet until I open the throttle to almost exactly 2,250 revs and the engine then seems to miss and the revs drop back. If I keep the throttle open at that same spot she’ll repeatedly build engine speed up to 2,250 then stutter and fall back. No way will she rev over 2,250 and it almost feels as if a limiter is kicking in as, right up to that speed, the engine fires faultlessly.

At one stage I’d suspected a head gasket problem as there seemed to be rather too much steamy exhaust for comfort when the problem is there so I’ve had the engine compression tested and all cylinders are fine. I’ve trawled this and other web sources for anyone who’s had a problem with the same symptoms, but to no avail. There are so many sensors and feedback systems that I’m not sure where to look first. Now she’s playing up again I have a mechanic who is going to have a look at it but I’d greatly appreciate any ideas or suggestions to start us off.

Many thanks. Dave

This might be a bad throttle position sensor. You should get the diagnostic fault codes checked. This is quite easy to do yourself, if you get hold of:



You can also check the codes if you have a voltmeter with an oscilloscope function. Or follow the instructions here:



But the book is also good to get hold of; its cheap, and has some additional information in.

Hi AT. Many thanks for the reply. When this fault first occurred I did print off those error code analysis instructions and bought the few components to make an LED tester, but then the problem cleared and I left well alone. I guess I need to dig out the instructions and find the LED bits and my solding iron!

 A quick update. Spent an hour in the rain with my mechanic friend  today. Engine still kept cutting out when speed built to 2250. He was sure it wasn’t a misfire but some form of electrical problem in the engine management circuitry. We rigged up the led fault code reader and plugged it in. The led lit up fine but when gnd and ten contacts were bridged the light dimmed back and no error codes were flashed - so either no errors are logged or they are not reaching the diagnostic box! 

Trial and error then! Next he unplugged the crank angle sensor, checked the contacts (which looked OK) then reconnected. Then he unplugged the Air Flow Meter (AFM) and checked the contacts inside the plug - one looked bronzed in colour as did the mating contact in the AFM and he suspected a possible case of overheating.

We reconnected the AFM then I started her up again. Ran perfectly! No problem revving way past 2,250. So, maybe coincidence, or maybe a bad contact in either the AFM or crank angle sensor, or a failing AFM. Next step is to run her and if/when the problem returns then disconnect/reconnect the crank angle sensor and restart to eliminate or confirm the problem is there. In the meanwhile I’ve decided to source a replacement AFM anyway as the bronzing of a contact isn’t a good sign. AFMs cost £409 from MX5Parts (gulp

 (posted last item too early!)

(gulp {#emotions_dlg.shock}) but I’ve found a functioning one on eBay for less than £26 delivered, so decided to buy that and check it out and, if OK, I’ll swap out the current AFM and keep my fingers crossed.

The ‘bronze’ contacts are in fact gold plated in order to eliminate the possibility

of corrosion (they carry a very small signal). The other contacts can get a bit corroded,

but it is quite unusual.

Thanks for the info, Ralph. Actually, that’s rather disappointing news as I thought that perhaps we’d pinpointed the problem at last! Just one pin out of eight being a different colour seemed a bit unusual. Unless we had a serious dose of coincidence though, disconnecting then reconnecting just the crank sensor and the AFM seemed to make the problem go away (maybe when I restart her today it’ll be back though - it does seem to have an Arnie Schwarzenegger habit!). I’ve bought the AFM from eBay - at that price it doesn’t harm to have a spare in the garage, even if I don’t need it right now.

Given that we couldn’t get any fault codes out of her we are now in trial and error mode and any hints or bits of info are very welcome. Many thanks. 

Thought I’d give an update to anyone who may be interested in this problem.

I checked the mechanism on my second user AFM, cleaned it up, and tested the wiring (it tested within spec). I swapped it for the one on my car and the problem was still there, although it did take a little while to return! {#emotions_dlg.sad}

I thought I’d try the error code check just once more and this time it actually started flashing at me! {#emotions_dlg.smile} Error code 34 (Idle Speed Control Valve) repeated again and again, so no other faults logged. I wasn’t sure that this was related to my problem though as I had experienced occasional idle speed problems since I bought her, so it may have been an “old” code.

I disconnected and reconnected the ISCV and pulled the BTN fuse for around 30 seconds to wipe the old codes from memory. I checked for error codes and found none this time, so I assumed that the 34 code had been wiped. I restarted her, but it took a little while before I could promote a stutter from the engine again (and that made me suspicious of the ISCV connector contact wiring) but eventually I got a couple of hiccups (but nothing like previously).

I reconnected the error checking LED and, lo and behold, error code 34 was back! I tried to test the ISCV plug contacts but they are next to impossible to reach with the two multimeter probes - too much “stuff” in the way. I think I must have got the probes onto the contact pins at some point (you can’t see the top one, and only just see the bottom one before your hand gets in the way as it directs the probe!) but the required resistance reading never materialised!

Because of the idling problems, back last year I acquired a second user throttle body (TB), complete with ISCV and Throttle Position Sensor (TPS). I cleaned up the TB as soon as I received it, so yesterday I checked the ISCV and TPS circuits on a multimeter. The ISCV passed, but the TPS needed a slight adjustment. I have to get hold of a new TB gasket then I plan to swap the complete TB/ISCV/TPS assembly, hopefully next week.

I like to think that I’m closing in on the culprit at last (not much more to change after the TB/ISCV/TPS - oh yes, coil pack and engine coolant sensor still to go!!!)  {#emotions_dlg.confused}

OK guys and gals, here’s hopefully (!!!) a final update. I went along with the error code 34 (Idle Speed Control Valve - ISCV) and yesterday, with the help of a friendly local auto mechanic, swapped my existing throttle body/idle speed control valve/throttle position sensor with an identical assembly that I obtained off eBay. I did clean up the eBay unit and check all the electrical resistances at the pin connectors first.

The swap was relatively straight forward, except for the gasket which had become brittle and stuck fast to the inlet manifold face plate. That took ages to carefully scrape off and required the two fixing studs to be removed from the manifold first.

Apart from a sticky dashpot on restart which sent the revs up to 4,000 and kept them there as soon as I touched the throttle pedal, everything seemed to work as it should after start up. After she’d warmed up we reset the base idle speed and checked throttle cable travel then I took her out for a run. She seemed to go perfectly for some while until a couple of engine blips as I tried to accelerate in 2nd after a T-junction right turn - my heart sank! But that was the only hiccup, so I’ll reserve judgement for the moment.

The basic problem appears to have gone though - she was undrivable before - and a check of the electrical resistance across the two pins on the ISCV shows no reading, so that is definitely faulty anyway and needed replacing.

Took her out for a longer spin this morning and no hiccups whatsoever - ran really sweetly. So maybe the cause of the problem was the ISCV and the error code was entirely trustworthy. I've been having idle problems ever since I bought the car and the previous owner had increased the base idle dramatically to overcome the drag caused by the aircon compressor which, of course, should be compensated for automatically. So possibly the ISCV has been failing intermittantly for some while but it is interesting that, if so, it has thrown up a variety of problems, the most serious of which didn't have anything to do with how the engine idled!

If my experience helps anyone else with a similar problem to get to the solution a little quicker then so much the better. Be aware though that a new ISCV from Mazda costs way over £500 and even in excess of £450 from MX5 Parts! If you need to replace yours then try to source it from a breaker but be sure to use a resistance meter to check that the electonics are working as they should (12 Ohms across the two pins, + or - 1 Ohm) before fitting it.

 Can’t the valve be rebuilt/repaied by itself ?

Hi Simon. Unfortunately, no - unless you’re a competent electrical engineer, which I’m not. If the unit is just gummed up and needs a good clean to free up the moving shaft then, yes, that is a DIY job. But the probability is that the fault is going to be caused by the electrics and that part is not designed with repairability in mind! The electrics are sealed in a hard plastic housing and there are virtually no service components inside - it’s basically a solenoid.  Even if, for example, the fault was caused by something as simple as a broken wire to one of the terminal pins, the wires are extremely thin and embedded in the plastic, so you’d have to carefully grind away all the plastic to expose the wires, probably destroying the wires in the process.