Immobiliser/ECU Car won’t start

  1. My model of MX-5 is: Mazda MX5 MK1 1996
  2. I’m based near: Newmarket
  3. I’m looking for technical help or recommendations on: Hello all, I bought my first ever Mazda Mx5 MK1 today with a 1.8 engine, I bought it from a mechanic who unfortunately was unable to finish the repairs due to personal reasons - I was told from a seperate garage that the immobiliser was faulty - however they only replaced the ECU and it will not crank - they directly tested the fuel pump and it is working as it should - I have just bought a full kit including a new ECU,keys, Immobiliser, barrel and all door locks as a matching set - will this fix the issue as I see this is a common fault?

I have attached some pictures of the ecu and immobiliser (standard factory)

Thanks all



Hi. Yes, if you have bought a matching, working set of ECU, immobiliser, keys and locks then that combination should work. Of course we can’t guess whether the car had any other faults beyond the ECU/immobiliser, but the pictured BPU2 ECU should be the right model for a late Mk.1 so that bit should be okay.

Thank you!

So I have now replaced the ECU, Immobiliser etc and it now cranks and the starter motor and I can hear the fuel pump but it isn’t starting. Any ideas?

So I bought the full kit with ecu,immobiliser barrel etc however tried and still did not start. The car cranks but the fuel pump does not activate UNLESS it is bridged by bypassing it - however the car does STILL not start. What could be causing this and has anyone had this issue?

Mazda mk1 1996 1.8

Unless what is bridged by bypassing what?
Have you tried replacing the relay that serves the fuel pump, it may serve other vital things too.
I feel your pain because I went through all this with my Ducati 999. I replaced everything in sight to no avail and it eventually turned out to be a broken wire, inside the insulation, providing power to the fuel pump.

So basically, we took the relay out and put a wire into the 5 pin (i think) and bridged it into it self and the fuel pump started but the car still would not start’

Even though the car won’t start yet, that still sounds like progress in that you know you have a problem there and that problem may turn out to be the problem. Substituting the relay is well worth a try, if that doesn’t get the pump running, presumably that means the relay isn’t getting a trigger signal for it to be energised.


What do you think it could be - maybe no spark?

It would seem a coincidence to have no spark as well as no fuel pump, although I presume that could be arranged via the ecu and immobiliser.
Does the relay energise when you turn on the ignition?? You should be able to hear it click, you should also be able to feel it if you put your hand on it. The relay is basically a miniature solenoid that acts as a switch. When it is energised, the solenoid makes a connection in the same way a switch would.
Being an electro-mechanical device, they can get sticky with age and corrosion, although they are pretty well protected in this environment.

Let me give that a test when I get home and I will let you know!

Thank you for that advice!

Maybe a daft question but is it a factory fitted immobiliser or an aftermarket unit?

Not daft at all! It’s a factory fit immobiliser :slight_smile:

So to sum up?
The fuel pump only runs when a jumper is installed.
The engine cranks but no attempt to fire.

Can you check for a spark? My guess is there won’t be one.
I would still suspect an immobiliser problem. Maybe just bypass it ( if that’s possibly on that model) and see if it starts.

With so much unknown history as to what other people have done it sounds like a bit of a nightmare.
If you like, PM me your email address and I’ll dig the circuit diagrams out.

1 Like

I’m slightly anxious that a non-running fuel pump sounds like the kind of thing the immobiliser might cause, but let’s assume for now the new ECU/immobiliser is working okay.

I’m a bit confused about exactly where you stand now and which symptoms have changed. Do I gather correctly that when you got the car it would not crank but with the new ECU it now will? And you said something about hearing the fuel pump but later said you had to bridge it to get it to run - is it possible the pump primes when the ignition turns on but doesn’t run after that? Or have I misunderstood?

What I might be inclined to do is try to read any fault codes from the Diagnostics port with an LED. Perhaps the most likely (non-immobiliser) problem that would prevent the car from even trying to start would be no timing signals coming from the cam angle sensor. Could be a faulty CAS or broken wire.

Do you know if you’re getting any spark while cranking? A timing light would tell you. Alternatively you can unscrew one sparkplug and rest it on the cam cover while cranking. Presence of spark would indicate the CAS is working.

Good idea with the timing light :slight_smile:
Must remember that one

Thanks Martin, I think I found the cause - the issue appeared to be a faulty timing belt (pictured) we have replaced it and it started however the idling is exceptionally poor. Has been sitting for over a month.


Well done for finding that. Now it’s running I’m sure you’ll get the rest sorted.

1 Like

Blimey. Uhh, yeah, that would stop it running. :slight_smile:
Glad to hear you’ve got it started, that’s probably most of the battle.

1 Like

I think maybe a compression test is in order, I can’t see how the valves could have survived that
Also, I can’t help thinking about what caused the teeth to strip off in the first place. Did something seize??

1 Like