PRHT won't close

Hi all, I suppose it was only a matter of time  before I get into it, the roof has been raised/lowered perhaps a 100 times in my ownership ( not a lot, I know) and has behaved perfectly and quietly and smoothly. I don’t have the PRHT roof module fitted either.

So, I went into the garage to get the car out earlier. Roof was down so started car, reversed out onto level ground, in neutral, handbrake on, engine running and pressed and held the close button. Windows (both) dropped a few inches, Rear deck fully raised itself and that was it, no more roof action 

Press close and rear deck lowers and main roof drops slightly into its final resting place, long beep and all good. Tried again, same thing happened. Windows dropped further, rear deck raised fully then stopped. 

So far;

  • Checked that both silver button head bolts on the mechs at either side were fully tight.
  • Checked that boot was fully closing ( i tried operating with boot open and nothing at all, tried with boot closed and rear deck raised itself as described)
  • Checked both L/R RHT 15A fuses plus KEY2 and ROOM ( all OK
  • Disconnected the battery for a while to see if it might reset
  • Took window switch out, sepearated the parts, PCB (my untrained eyes) looks OK from behind, no dry joints. Contact cleaned both the plug and the socket. Reconnected without the console in place to ensure a good connection but no difference. Windows both drop when attempt to raise the roof. Both work absolutely fine in normal operation, never been a problem.
No funny noises coming from rear when raising lowering the deck. If the button is released (closing cycle) and then pressed again, each time I press it, I can hear something like a relay trying to work? but no movement. 

Read loads today from Internet but most discussions left me hanging with no helpful final conclusions, others weren’t the same issue. I’ve also read (Internet) that you can manually raise the roof if the rear deck is raised? Without disconnecting the gears and tying it all up with the supplied Mazda string? 

Any DIY suggestions? Anyone had the same issue and managed to sort it? Don’t particularly want to go to Mazda if possible (many ££££££’s has been mentioned on threads) Stumped now 



hi barrie ,

sorry to hear this (  i’m sorry i can’t offer any help .  ) but i hope there is a simple solution .

good luck pal. 

Okay, to be honest I’m just copying stuff from another post, so no credit on my behalf.
Check out this thread.

Also this was posted by Drumtochy so all credit to him ( thanks Eddie )

" You can download the full Mazda diagnostic software to a PC laptop after logging onto the Mazda European Portal. Cost for a three day unlock code of the software Euro 30. You also need a USB adaptor.  USB to ODB2. "

Please keep us informed as these rarely seem to go wrong so all information much appreciated.

Good luck and keep us updated.


Not sure your link has posted? 




As above with Geoff.

There is a similar thread circulating at the moment, also no smart module - hopefully there will be a quick and simple resolution provided very shortly.

Here it is Barrie but no solution and not sure if it is exactly the same issue.

My only suggestion is something physically stopping progress but I’m sure you would have noticed that Barrie?  

Hopefully my edit now has the info. ( website playing up again )

1 Like

It’s got me stumped ( easy enough though) what’s upsetting me and is frustrating me, I’ve spent quite a bit on cosmetics/mods as usual and this might just bust the bank as it were  wasn’t expecting this at all, was all working very nicely thankyou! Oh well, as you say, hopefully someone will have the answer, I don’t mind rolling my sleeves up if it can be DIY sorted and if s, threads like this will assist others in the future. I’ve read that these roof systems are quite robust so hopefully nothing major. It’s funny that it just happened though, no prior warning of anything amiss 



Thank you Combemartian, all contributions gratefully received  I have mellens downloaded so will have a look.



I’m searching - just a thought 

Sorry! - just re-read your comprehensive first post and see that this has already been well and truly despatched as a cause.

My own thoughts are that anything clunky, awkward, noisy, brutal and similarly demonstable will be a physical problem.

If there is a silent objection probably an electronic sniper in the works - microswitch, misaligned sensor, relay, etc.


Maybe a faulty microswitch - not detecting that the deck panel’s fully raised, so no signal that the roof can then move?  Or perhaps a duff relay somewhere?  I think if it was the window switch then one (or both) of the windows would fail to drop also the deck panel wouldn’t lift up.

Hope that you get it sorted without a lot of expense Barrie.

Okay, I know this is probably a really dumb suggestion, but electronics can be stupid some times. As a service engineer the number of times I fixed stuff by turning it off and on again is unbelievable.
How about disconnecting the battery for 5 minutes, reconnecting and trying again. The ecu will have to relearn its settings and the DCS will need resetting but what the hell, it may work. ( stranger things have happened )



he has tried that already ( see first post )

could be worth trying again , for longer ???


Can you close it manually, using the supplied handle?

At least then you will know it is an electrical , not mechanical, fault.

Hi BlueBird - there’s no handle for manual closure.

According to the handbook, it’s necessary to disconnect the two allen bolts using the tool provided (they’re only accessible with the roof down), lift up the deck & then lift up the roof, pulling it forwards to close.  The deck then has to be fastened back down with the string provided which goes on to lugs under the deck & adjacent to the bottom part of the boot hinges.  So as far as I’m aware the manual closure process bypasses the electrical & the mechanical aspects of the operation.


Hi again, did disconnect for a minute or so previously but I’ve had another go, will leave it off for a longer period. Thanks



there are micro switches on the drivers side on the deck mechanism. One is to tell deck fully open (I think) and the other is fully closed (again I think). They have a blueish coloured body. They look near impossible to get to but I think the lower one sends a signal to the roof ecm when the deck is fully open to allow the hardtop to move. I suspect that there is a problem with this switch, maybe dirty contacts, could try spraying it with contact cleaner. 

If you switch the ignition off with the deck fully open you will see a small arm on each switch which a lug hits, this arm operates the micro switch. Make sure you haven’t caught one of these arms and it is now misaligned. 

(I can see another micro switch on the hardtop hinge on the drivers side. But on this occaison I think the deck on is at fault.)


“So as far as I’m aware the manual closure process bypasses the electrical & the mechanical aspects of the operation.”

Yes, by undoing the button head bolts and inserting the ‘eye’ rod, it disengages the gears, so it’s not connected mechanically as such. Thanks anyway BlueBird  all suggestions recievied with thanks!

When I went out to the car to disconnect the battery, I went back in the boot and took all the trim off and the metal cover over the fuel pipes. I had a daft thought that I’d disconnected some of the wiring to gain better access to the top mount on the new suspension? Alas, no such luck  I did give everything a good blast of contact cleaner though!


Hiya Richard and thanks for that suggestion, I saw two switches on the drivers side and their metal springy contacts. With the deck open, and ignition on with the red light lit on the close switch, I pressed the top springy contact and the light went off, tried it on the bottom one but nothing happened, I have applied copious amounts of contact cleaner so will have another look, thank you



It may be worth checking the roof ECM multiplug. Bit of a pig to get too and disconnect, have a look at the first two photos on this link for its location: -

I would disconnect and then spray with your contact cleaner.