Unable to stop NC1 alarm

My NC1 2.0 Sport alarm started going off this morning; sounding for a minute or so then stoping for 30 seconds, only to start again. Indicators are not flashing while it does this and there are no lights on the instrument cluster.

I’ve tried to cancel it using the key fob, unlocked and re-locked the car manually as well, opened and closed doors, bonnet and boot and tried to cancel again but nothing I do is stopping it.
There is no mobile phone in the car.

After about 10 minutes it stopped of of its own accord but started up again 5 minutes later and again I was unable to cancel it.

I’ve searched the forum but there appears to be no-one having quite this problem where they are unable to stop a sounding alarm.

Added - Boot and bonnet microswitches working OK.

Currently quiet, but just waiting . . .

Has it been in rain recently or maybe recently washed? I’m thinking that you may have water leaking into the car from a scuttle grommet.
Check the passenger footwell for dampness/water, also look for moisture inside the fuse box in the passenger foot well.


Thanks Richard. No rain and I sealed the scuttle grommets a while ago; totally dry inside and had never leaked on the driver side…

The sounder is behind a boot panel in the LHS corner.
Is the control unit there too or is that up front?

There is a module under the center consol between the seats. Also worth checking the micro switches that are built into the bonnet and boot locks.

This may be of help:-


Phone left in the car?

No phone in car.

The strange thing about this is that I can’t stop it once it’s going, either with the key or manually unlocking.
I can start the car while the alarm is going, so not immobilized.

I think this all points to a problem with the control module so initially I’ll disconnect / reconnect the battery and see if it happens again.
It’s actually been quiet for the last hour, so just maybe . . .

If this becomes a regular problem and someone knows a way to knobble the alarm sounder before I sort it, if they could pm me. My neighbours (and myself) would be grateful :smiley:

It’s going again!!!

I guess you’re probably right.

Again water damage can take a while to show through, even after drying out.

There is a relevant module in the grommet vulnerable place. Taking that out and carefully washing it free from contamination might fix the problem - but unlikely once the damage is done. I don’t know where you will find a replacement, probably need to bite the bullet and ask Mazda to fix it.

Electronics has a well-known state called “walking wounded” where it seems OK for a while after an unfortunate “event”, but is actually damaged and on its way out.

And some things simply reach end of life, like the SDHC chip in my phone two days ago, fortunately it was already backed up.

1 Like

Thanks Richard.
Is the module LHS or RHS?

(Know all about ‘walking wounded’. Caught out big time in the capacitor plague at the turn of the century. Routers, servers PCs, running fine . . . until they were power-cycled!)

Did you cancel the interior sensors, anything buzzing around in the car could set it off?

High up on the left, close to where the water comes in is a connector going to a lock/security module, but ONLY IF ONE IS FITTED. If you don’t have full “Advanced Keyless Entry” (ie you only have the normal UK four-push-button keyfob “Keyless Entry” like most of us) you don’t have the module, BUT the water can get into that connector to cause grief.

Here is a pic of plug, but no module, only a small amount of rusty metal behind it where I caught the leak in good time. The dashcam power supply lives roughly where the module would have

However this is just the start. There are several other relevant bits scattered around the car, (including PCM, TCM, PRHT, etc) and they all talk to each other. This is why the diagnostic procedure in the manual uses the M-MDS (Mazda Diagnostic System) tools.

Have a look at this page for the “Keyless Entry” and those subsequent for the NC in USA, most of it is the same, just L-R swap on a few dash and control items.

In the introduction it mentions possible fault codes will be shown on the security light. They should help narrow down an initial search. (They are listed diagrammatically a few pages later, nice and clear.)

This is why I suggested asking Mazda. I expect you are not the first they will have encountered, and they have the tools for quick diagnosis.

Good luck.


That’s great info - Many thanks Richard.
I’ve got the standard 4 button fob so I’ll check that connector.

Since I last posted I’ve done a battery disconnect and reconnect after 5 mins (and reset DSC) and been out and about, leaving it in 2 different car parks. In one I would have heard the alarm if it had sounded and in the other I wouldn’t but I hung around near it after returning, which gave me a chance to look at a rather smart green Eunos in Cheltenham Morrissons car park with something interesting under the bonnet, going by the turbo boost gauge on the instrument panel.

The alarm hasn’t sounded at all in that time, so I’m keeping fingers crossed it may have been some transient state resolved by the battery disconnect. I’ll give the connector a check anyway.


If the indicators aren’t flashing then that points to the alarm sounding from its internal back-up battery. Either the siren is loosing its 12 volt feed or ground or it has an internal fault.

1 Like

Thanks Robbie.
I tried to locate the sounder in the LHS corner of the boot but it’s obviously well embedded for security reasons. Is it possible to access it at all to check supply / grounding?
(Please PM me if you can advise; I understand if you can’t.)

What’s the condition of the car’s battery?

A low battery can set some car alarm systems off - and, as mentioned, not having the indicators flashing could mean that the siren is using its back-up battery to sound.

That you have had no problems after driving the car (and so putting some charge in the battery) may also point to a low battery.


Thanks Philip.
Battery was new last year and a few decent length runs recently so I don’t think that was the problem. No indication of a battery problem in the way it turns over and starts.

Saying this very quietly so as the car won’t hear but it has been OK since I did a battery disconnect / 10 minute wait / reconnect. There was slight amount of corrosion on the terminal contact area so I cleaned them up before reconnecting. Fingers crossed . . .

1 Like